Jam - Azure service degradation – Incident details

Azure service degradation

Resolved
Degraded performance
Started 4 months agoLasted about 2 hours

Affected

Azure Integration

Operational from 6:47 PM to 8:59 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified

    Due to an issue with third-party API, users can experience slow performance creating Azure integrations. We're aware of the issue.

    https://azure.status.microsoft/en-us/status